Сви главни прегледачи одбацују ТЛС 1.0 и 1.1 у 2020. години

Сви главни произвођачи веб претраживача објавили су 15. октобра 2018. године да ће прегледачи који производе престати подржавати стандарде ТЛС 1.0 и ТЛС 1.1 2020. године.

Промену су на веб локацијама компанија најавили Гоогле, Аппле, Мицрософт и Мозилла.



Безбедност транспортног слоја (ТЛС) је безбедносни протокол који се на Интернету користи за заштиту интернет саобраћаја. Користи шифровање како би заштитио податке од прислушкивања.

ТЛС 1.0 и ТЛС 1.1 су стари стандарди. ТЛС 1.0 је ове године навршио 19 година, и то врло дуго на Интернету. Главни проблем са ТЛС 1.0 није што протокол познаје сигурносна питања, већ што не подржава модерне криптографске алгоритме.

С друге стране, ТЛС 1.1 користи само 0,1% свих веза и иако адресира нека ограничења од ТЛС 1.0, новији стандарди попут ТЛС 1.2 или ТЛС 1.3 боље су погодни за напред. Такође је релативно стар јер је навршио 10 година недавно.

Употреба модернијих верзија протокола побољшава перформансе и сигурност веза увођењем функција као што су савршена тајност напријед и отпорност на нападе повезане са падом. ТЛС 1.2 је такође захтев за ХТТП / 2 који нуди побољшања перформанси када се користи.

tls 1.0 1.1 deprecation

Подаци телеметрије прикупљени од произвођача произвођача показују да више од 99% веза већ користи ТЛС 1.2 или новију верзију. Око 0,5% свих ХТТПС веза у Цхромеу користи ТЛС 1.0 или 1.1, а бројке су сличне за остале прегледаче.ТЛС 1.3 финал објавила је Радна група за интернет инжењеринг у августу 2014. године.



Ово је велико ажурирање ТЛС 1.2 која значајно побољшава брзину и сигурност везе. Један од главних пораста брзине је спуштање на једно окретање умјесто руковања (ТЛС 1.2 користи два преокрета). Све више и више страница на Интернету прихвата ТЛС 1.3 да би користили предности које стандард нуди.

Мозилла Фирефок, Мицрософт Едге, Гоогле Цхроме и Аппле Сафари укинуће подршку за ТЛС 1.0 и ТЛС 1.1 у марту 2020. године.

Промјена утиче на велики број веб локација и услуга. Иако се многи могу надоградити на подршку само за ТЛС 1.2 и ТЛС 1.3, веб локације и уређаји који више нису подржани можда никада неће добити ажурирања за подршку овим новим верзијама.

Ево линкова до најава:

Сад сте: Шта мислите о најави?